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1 Obrada slika korištenjem programa GIMP 

1.1 Upoznavanje s okruženjem i alatima GIMP-a 

GIMP (engl. GNU Image Manipulation Program) je jedan od najraširenijih slobodnih programa otvorenog 

koda koji se koristi za obradu i stvaranje slika. Radno okruženje se sastoji od sljedećih elemenata (Slika 

1.1): 

- Traka izbornika sadrži sve izbornike za rad s dokumentima. 

- Alatni okvir sadrži sve alate za nanošenje boje, crtanje i selektiranje. 

- Okvir s alatnim opcijama sadrži različite opcije trenutno aktivnog alata. 

- Prozor dokumenta prikazuje otvorene dokumente, gdje svaki dokument ima svoj prozor s 

pripadajućom trakom statusa, a unutar prozora može biti prikazana bilo koja slika ili se slika može 

stvarati i od početka. 

- Okvir sa slojevima sadrži sve slojeve otvorenog dokumenta. 

 

Slika 1.1 Radno okruženje GIMP-a 

Stvaranje novog dokumenta: Odabirom File > New se pojavljuje dijaloški prozor New u kojem se 

postavljaju razne postavke slike (visina i širina dokumenta, razlučivost dokumenta, režim boja, vrsta 

pozadine) (Slika 1.2). Novi dokument se može stvoriti i putem već definiranih postavki predložaka (u 

dijaloškom prozoru New) (Slika 1.3). Ovisno o odabiru, prikazuju se dodatne razne moguće opcije. Bitno 

je naznačiti da stvaranje novog dokumenta ne znači istodobno da se taj dokument izravno sprema. 

Odnosno, dokument se nakon stvaranja mora spremiti na željeno mjesto. Pri spremanju dokumenta, 

potrebno je znati ciljno odredište dokumenta. Ako je riječ o nedovršenom projektu, tada se ostavlja u 

obliku projekta GIMP (ekstenzija .xcf), a ako se dokument želi objaviti na internetu, tada bi bilo najbolje 
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dokument spremiti u grafičkom formatu JPEG (engl. Joint Photographic Experts Group), GIF (engl. Graphic 

Interchange Format) ili PNG (engl. Portable Network Graphics).  

 

Slika 1.2 Dijaloški prozor raznih predložaka kod stvaranja novog dokumenta 

Dijaloški prozor Save (File > Save As) nudi mogućnost imenovanja dokumenta, odabiranja formata, mjesto 

spremanja i razne druge opcije. Opcija Color space (Slika 1.3) predstavlja odabiranje režima boja, odnosno 

određuje se kako će GIMP prikazivati i prikazati sliku. RGB Color je režim boja koji je najbolji za slike u boji 

koje su namijenjene mrežnom objavljivanju i u upotrebi u multimedijskim projektima.  

 

Slika 1.3 Dijaloški prozor stvaranja novog dokumenta 

Za ispis crno-bijelih i dvotonskih slika, koristi se režim Grayscale, koji koristi jedan kanal s maksimalno 26 

nijansi sive.  

Osnovni alati GIMPa se nalaze unutar alatnog okvira: 
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- Alati za odabiranje (engl. selection) služe za odabiranje određenog područja slike kojeg je 

potrebno promijeniti (ostatak slike ostaje netaknut) ili za stvaranje određenih likova. Alati za 

odabiranje su sljedeći: 

- alat za odabiranje ili stvaranje pravokutnog područja (engl. Rectangle ),  

- alat za odabiranje ili stvaranje eliptičnog područja (engl. Ellipse ), 

- alat za odabiranje ili stvaranje prostoručno nacrtanog područja (engl. Free ), 

- alat za odabiranje ili stvaranje graničnog područja temeljem boje (engl. Fuzzy ), 

- alat za odabiranje ili stvaranje područja sa sličnim bojama (engl. SelectbyColor ), 

- alat za odabiranje oblika korištenjem opcije uspješnog prepoznavanja rubova (engl. 

Scissors ),  

- alat za odabiranje područja koje sadrži prednje (engl. foreground) objekte (engl. 

Foreground ), 

- Alat za pomicanje može pomicati odabrano područje ili cijeli sloj (engl. Move ). 

- Alat za izrezivanje dijelova slike (engl. Crop ) omogućuje izrezivanje dijela slike. 

- Alati za crtanje omogućavaju stvaranje vlastitih likova i pozadina, a mogu biti: 

- kistovi (engl. Paintbrush , engl. Airbrush ) se koriste za slikanje s mekanim 

rubovima (na traci s opcijama se mogu mijenjati postavke kista), 

- olovka (engl. Pencil ) se koristi za slikanje s oštrim rubovima, a uglavnom se koristi 

za izmjenu pojedinih piksela uvećanih slika s alatom za zumiranje, 

- gumica za brisanje (engl. Eraser ) briše piksele s platna, 

- kantica  (engl. Bucket fill ) popunjava bojom neko odabrano područje, 

- Alat za pisanje teksta (engl. Text Tool ) stvara slojeve teksta. Omogućava dva načina pisanja 

teksta, gdje prvi predstavlja odabiranje alata i početak pisanja po platnu, dok se drugim načinom 

odmah određuju granice područja teksta da bi se onda tek započelo samo pisanje. 

- Izbornik boja (engl. Color Picker ) omogućava odabir boje za boju pozadine (engl. 

background) i pokrivnu-prednju boju (foreground). 
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- Alat za kloniranje (engl. Clone , engl. Perspectiveclone ) omogućava kopiranje 

određenog dijela slike na nekom drugom dijelu te iste slike. 

- Alat za zumiranje  (engl. Zoom) pri promjeni veličine prikaza slike, može određivati koji će 

dio slike biti prikazan, a da se slika pritom ne mijenja, a također omogućuje promjenu razine 

uvećanja slike. Dokument GIMP-a se može najviše povećati 800%, a najmanje 12,5%. 

Sloj (engl. layer) je jedna od značajnijih osobina programa za obradu slika. Sloj omogućava rad na jednom 

dijelu slike dok ostatak ostaje netaknut. Svaki dokument može sadržavati više slojeva. Svaki novi 

dokument sadrži pozadinski sloj te svaki sljedeći pridodani sloj je transparentan dok mu se ne pridoda neki 

tekst ili slika.  

Rad sa slojevima se može povezati s radom s folijama. Na folijama se može nešto obrađivati, a da to ne 

utječe na ostale folije koje se nalaze ispod ili iznad trenutne folije, a na kojima se također može nalaziti 

neka slika. U slučaju da se od tih folija napravi jedna slika, odnosno da se svi elementi sa svih folija spoje, 

tada skup tih elemenata postaje jedinstven i dostupan iz tog jednog sloja. Ako se želi nešto grafički urediti 

(pomaknuti, drugačije obojiti i slično) potrebno je obratiti pozornost koji sloj je aktivan. U slučaju da se 

želi odabrati neki element slike koji se nalazi na drugom sloju, a trenutno je aktivan peti sloj, tada je 

potrebno prebaciti se na drugi sloj kako bi željena akcija bila moguća. 

Ako slika ispunjava uvjete i želje, tada se svi slojevi spajaju uz pomoć funkcije Merge na prozoru sa 

slojevima. Tako stvorena slika se više ne može vratiti na onu početnu, odnosno ako se ikad kasnije poželi 

nešto promijeniti, to neće biti moguće jer su svi slojevi spojeni u jedan. To navodi na to da se prije spajanja 

svih slojeva, dokument sa svim slojevima spremi za kasnije eventualno mijenjanje dokumenta. Slojeve je 

moguće grupirati, sakriti, preimenovati, mijenjati njihovu transparentnost (engl. opacity) te im pridodavati 

različite stilove (više o tome u primjerima). 

 

1.1.1 Primjer 

Sljedeći primjer pokazuje načine korištenja sljedećih alata: selektiranje, pomicanje, rotacija, okretanje 

(engl. flipping), promjena veličine dijela slike, stvaranje pravokutnog područja, pisanje teksta. 

Veličina odabranog područja se mijenja odabirom Free Select Tool > Image > Scale Image . Nadalje su na 

isti način navedeni odabiri, koji predstavljaju korake u procesu obrade i izradi slika (prikazani znakom 

), a gdje je svaki korak popraćen slikom postupka. 
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 Odabrati šešir i potom opciju Copy > Otvoriti novi dokument > Paste. 

 Desnim klikom na sloju Floating Selection (Pasted Layer) odabrati opciju To New Layer . 
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 Odabrati Scale Tool i kliknuti na šešir te prilagoditi veličinu. 

 

 Alatom Move se pomiče element slike na željenu lokaciju. 
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 Potrebno je odabrati sliku i desnim klikom odabrati  Tools > Transform Tools. 
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 Kako bi se šešir okrenuo potrebno je odabrati šešir i alat Flip . 
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 Kako bi se slika Vilme zarotirala, potrebno je odabrati alat Ellipse kojim bi se odabralo pravilno 

kružno područje te potom alat Rotate za rotiranje slike. 
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 Alat Color Picker omogućava uzimanje uzorka boje s određenog područja, u ovom slučaju sa šešira 

kako bi se ta ista boja mogla koristiti u neku drugu svrhu. 

 

 Alatom Bucket Fill se ispunjava pravokutnik odabranom pokrivnom bojom. 
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 Odabire se alat Text kako bi se napisao i oblikovao tekst „Lab1 – GIMP“. 

 

 Naredne dvije slike prikazuju finalno stanje slojeva i izgled samog primjera. 
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1.1.2 Zadatak 

Na Moodle priložiti rješenje prethodnog primjera, odnosno projekt (xcf) s vidljivim svim slojevima. 

 

1.1.3 Primjer 

Sljedeći primjer pokazuje način rada sa slojevima te korištenje alata za pisanje teksta, bojanje, postavljanje 

gradijenta, crtanje oblika elipse i drugo. 

 Stvoriti projekt predloška 800x600px. 

 Otvoriti sliku i prebaciti dio slike u projekt prema dolje prikazanoj slici. 

 Smanjiti sliku tako da se odabere slika na željenom sloju te smanji korištenjem opcije Transform > 

Scale. 
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 Gumicom izbrisati višak slike. 

 

 Bijelu pozadinu slike zamijeniti uzorkom po želji tako da se odabere alat Bucket Fill > Pattern Fill 

nakon čega se odabire željeni uzorak. 

 

 Stvoriti novi sloj imena po želji (primjerice patuljak). 

 

 

 

 



Haidi Božiković  16 

 Sloj može postati nevidljiv na trenutnom dokumentu ako se sa lijeve strane imena sloja isključi 

oko. 

 

 S druge slike prebaciti sliku patuljka i prilagoditi veličinu. 
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 Pozicionirati patuljka prema slici. 
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 Stvoriti novi sloj na kojem je potrebno nacrtati oblik elipse bojan određenom bojom ili uzorkom. 

 

 Nadalje je potrebno oblik posvijetliti i rotirati. 

 

 Potrebno je postaviti elipsu ispod patuljka (metoda drag drop, raspored slojeva je Background, 

elipsa, patuljak). 
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 Postaviti neprozirnost sloja elipse na oko 38%. 

 

 Slojeve elipsa i patuljak potrebno je povezati lancem, odnosno odabrati praznu kućicu desno od 

'oka' na oba sloja nakon čega se pojavljuje lanac, čime se ta dva sloja povezuju što znači da ako se 

nešto pomiče na jednom sloju pomiče se i na drugom sloju. 

 Između slojeva elipsa i patuljak potrebno je dodati novi sloj gradijent. 

 U alatnoj vrpci odabrati alat Blend te prilagoditi željeni gradijent. 
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 Kako bi se dobio željeni učinak gradijenta potrebno je povući crtu u određenom smjeru i pripaziti 

na prozirnost. 
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 Dodati tekst tako da se odabere iz alatne vrpce alat Text, postaviti svojstva prema želji i napisati 

tekst Bajke (pritom se stvara novi sloj). 
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 Odabrati alat Perspective i prilagoditi izgled teksta. 
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 Finalni izgled slike primjera bi trebao otprilike izgledati kao na sljedećoj slici. 

 

 

1.1.4 Zadatak 

Na Moodle priložiti rješenje prethodnog primjera, odnosno projekt (xcf) s vidljivim svim slojevima. 

 

1.1.5 Primjer 

Sljedeći primjer pokazuje načine korištenja sljedećih alata: fuzzy select, color picker, clone, crop, promjena 

veličine platna (engl. canvas).  

 Potrebno je otvoriti sliku te snimiti dokument u xcf formatu.  

 Uz pomoć alata Fuzzy Select selektirati dio poluotoka. 
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 S alatom Color Picker potrebno je odabrati neku boju sa slike te pomoću alata kantice (Bucket Fill) 

bojati tom bojom označeni dio. 

 

 Odabrati alat Clone i potom kliknuti na mjesto koje se želi klonirati tako da se pritom drži tipka 

Ctrl. Tako se obilježava područje te je moguće postaviti miš na bilo koji dio slike i lagano povlačiti 

mišem kako bi se na tom dijelu „prekopirao“ dio slike koja je prvotno obilježena. Primjer mogućeg 

rezultata kloniranja prikazan je na sljedećoj slici. 
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 Promjena veličine platna stvara dodatni slobodni prostor oko slike, a sama veličina slike ostaje 

nepromijenjena. Odabire se opcija Image > Canvas Size kojom se postavljaju željene dimenzije. 
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 Alatom Crop odabrati tri brodića te kada se zatamni neželjeni dio slike, tada je potrebno dvaput 

kliknuti ili pritisnuti Enter, kako bi se izdvojili brodići. Brodiće spremiti u posebnu datoteku imena 

tri_brodica.png. 
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1.1.6 Zadatak 

 Potrebno je otvoriti sliku te spremiti dokument u xcf formatu. 

 

 Izrezati sliku tako da se ne vidi donji dio slike gdje se nalazi zelenilo. 

 Klonirati manji oblak s lijeve strane (prema poviše). 

      
 Željenom bojom ispuniti veliki oblak s desne strane. 

 
 Za slučaj da se ne mogu izvoditi određenje radnje nad slikom, tada se duplicira sloj te se radi na 

novom sloju. 

 Potreban finalan izgled slike je prikazan na sljedećoj slici. 

 

 Na Moodle priložiti projekt (xcf) s vidljivim svim slojevima. 
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1.2 Rad s maskama 

1.2.1 Primjer 

Maske na sloju (ili maskirni sloj) se mogu zamisliti kao komadići kolaž papira, koji se mogu izrezati i 

direktno postaviti na sliku po želji. Kada se radi sa maskom, tada se nanosi crna, bijela i nijansa sive boje. 

Područja maske koja su prekrivena crnom bojom su transparenta, dok područja prekrivena bijelom bojom 

su nevidljiva, a nijanse sive stvaraju razne razine prozirnosti. Svaki sloj može imati vlastitu masku, a maska 

će kontrolirati samo elemente sloja kojemu je pridružena. 

 Otvoriti sliku te odabrati opciju Add Layer Mask na dnu prozora slojeva. GIMP će tada stvoriti 

masku i prikazati je desno od sličice (umanjena verzija slike, engl. thumbnail), a ako se želi urediti 

slika tada se odabire lijeva sličica, a za masku se odabire desna. 

 Kako bi se odredio oblik maske, potrebno je odabrati alat Brush, pripadnu veličinu, a za pokrivnu 

boju odabrati crnu boju. 

 Kako bi se alatom Brush nanijela boja, potrebno je odabrati prozorčić maske te dok se boja bude 

nanosila, tako će crna boja pretvarati informacije slike u prozirnost. 

 Nanošenjem boja potrebno je izdvojiti područja neba kao prema slici, a pritom u prozoru odnosno 

paleti Masks postaviti određena svojstva te maske. 

 Nadalje potrebno je dovući u projekt drugu sliku i postaviti pripadni sloj kao početni, kako bi ta 

slika bila 'ispod' slike s maskom. 

 Tim postupkom će se donja slika prikazati u dijelovima gornje slike s maskom. 
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Haidi Božiković  33 

1.2.2 Primjer 

Primjer prikazuje kako omogućiti da se dio slike prikaže u pravim bojama, a ostatak slike u crno-bijelim 

nijansama. 

 

 Odabrati opciju Colorize > Saturation > 0 kako bi se boje prikazale varijacijama sive boje (crno-

bijele). 

 

 Na duplicirani sloj, dodati masku opcijom  Add Layer Mask. 
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 S alatom Paintbrush, crne boje, odabrati jedan ili dva cvijeta kojima će se jedino vidjeti boja. 

 

 

 

1.2.3 Zadatak 

Korištenjem slika po želji, ostvariti efekt preklapanja dviju slika korištenjem maski. Na Moodle priložiti 

projekt (xcf) s vidljivim svim slojevima. 
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1.3 Uređivanje slika i primjena raznih efekata 

1.3.1 Primjer 

Za stvaranje zimskog ugođaja na fotografiji, potrebno je prvo dobiti crno-bijelu fotografiju tako da se 

odabere opcija Color Tools te se postave odgovarajuće vrijednosti za opcije Hue/Saturation, Levels i druge. 
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Primjeri korištenja navedenih opcija su prikazani na sljedećim slikama. 
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1.3.2 Primjer 

Kako bi se ostvario efekt da je fotografija nacrtana tehnikom mekane olovke, potrebno je pratiti sljedeće 

korake. 

 

 Početni sloj je potrebno dvaput duplicirati. 
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 Na prvi po redu sloju od gore, potrebno je odabrati filter Gaussian Blur te promijeniti način (engl. 

mode) iz Normal u Grain extract. 

  

 Potom je potrebno spojiti trenutni sloj s donjim korištenjem opcije Merge Down. 
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 Iz izbornika Colors odabrati opciju Desaturate > Lightness. 

 

 

 Odabrati opciju Colors > Curves > namjestiti krivulju prema slici, imajući u vidu da se efekt prilagodi 

odredišnoj slici. 
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 Odabrati način Grain Merge. 

 

 Stvoriti novi sloj. 
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 U prozoru patterns pronaći uzorak papira i dovući na platno na novom sloju te poslije odabrati 

način Overlay. 

 

 

 

 

 

 

 



Haidi Božiković  43 

 Prema slici namjestiti krivulju na Colors > Curves. 

 

 Odabrati Layer > New from Visible kojim će se stvoriti novi sloj. 
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 Na novom sloju postaviti filter Gaussian Blur. 

 

 Na istom sloju je potrebno promijeniti prozirnost sloja. 
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1.3.3 Primjer 

Cilj primjera je postići efekt HDR slike (engl. high-dynamic-range) na običnoj fotografiji. HDR predstavlja 

skup tehnika za stvaranje većeg dinamičkog opsega svjetloće nego što je moguće postići običnim 

fotografiranjem. 
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1.3.4 Primjer 

Primjer pokazuje kako na drugi način ostvariti HDR efekt prikazan prethodnim primjerom.  
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 Odabrati opciju Colors > Desaturate. 

 

 Odabrati opciju Colors > Invert. 
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 Odabrati način Overlay. 

 

 Potrebno je kopirati početnu sliku i dovući je na vrh. 
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 Odabrati način Lighten only. 

 

 Odabrati opciju Adjust Color Curves te prilagoditi vrijednosti. 
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1.3.5 Zadatak 

Na slici prema želji, ostvariti efekte po želji (npr. nešto slično kao u prethodnim primjerima). Na Moodle 

priložiti projekt (xcf) s vidljivim svim slojevima. 

 

1.3.6 Primjer 

Primjer pokazuje kako da se ostvari efekt da dio slike bude raspršen u više sitnih dijelova. 
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 Potrebno je izdvojiti sliku patuljka s pozadine i duplicirati sloj. 

 

 

 Potrebno je stvoriti novi sloj prema navedenim vrijednostima. 
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 Nad prikazanim slojem odabrati opciju Alpha to Selection. 

 

 Veličinu patuljka prilagoditi. 

 

 Za efekt slike koji leti prvo je potrebno povećati sliku korištenjem alata Scale. 
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 Sloj Floating selection treba usidriti pa se potom odabire dugme anchor. 
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 Nad prikazanim slojem odabrati opciju Add Layer Mask. 

 

 

 Na ovaj način (pogledati gornje dvije slike) će cijela slika na tom sloju biti transparentna, budući 

da je obojena crnom bojom. Odabrati drugi sloj i alat gumice i odabrati opciju vine (Tool Options). 
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 Otići u sloj s maskom i odabrati crni okvir i s istim alatom gumice, pazeći da je pozadinska boja 

bijela, brisati dijelove te slike i tako se pojavljuju dijelovi uvećane slike. 

 

 

 



Haidi Božiković  56 

 Budući da alat vine ima neke sive okvirne crte, potrebno ih je maknuti, tako da se odabere opcija 

Colors > Threshold. 
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 Kako bi „krhotine“ slike bile mekše, odabire se Gaussian blur. 

 Za ostvariti efekt vjetra potrebno je odabrati drugi sloj te filter distorts > wind, a vrijednosti ovise 

o samoj slici. 

  

 

 

1.3.7 Zadatak 

Na slici prema želji, ostvariti efekt prema prethodnom primjeru. Na Moodle priložiti projekt (xcf) s vidljivim 

svim slojevima. 
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1.3.8 Primjer 

Slike je moguće prezentirati na različite načine. Primjerice, zanimljivi način prikazivanja su polaroid slike, 

koje je moguće ostvariti na sljedeći način. 

 

 Definirati novi sloj dimenzija polaroid slika (10.2 x 10.5 cm). 
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 Ako se želi raditi kolaž različitih slika, treba duplicirati ovaj sloj onoliko puta koliko ima slika. 

 

 Odabrati samo jedan sloj > reset all filters, dodati drop shadow. 

 

 

 

 

 

 



Haidi Božiković  61 

 Za dodati sliku, odabrati opciju open as layers i smanjiti joj veličinu da stane u pripadni okvir. 

 

 

 Odabrati alat crop i označiti dio slike. 
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 Postaviti vrijednosti u cm 9.2 i 7.3 i pritisnuti tipku enter. 

 

 Dvaput kliknuti te odabrati u izborniku Layer > Autocrop Layer. 

 

 S alatima measure, move, pomjeriti sliku da je sa lijeve desne i gornje strane jednako udaljena od 

ruba. 
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1.3.9 Zadatak 

Oblikovati i prezentirati slike po želji. Na Moodle priložiti projekt (xcf) s vidljivim svim slojevima. 
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1.4 Rad s alatima za crtanje 

Alati za crtanje omogućavaju stvaranje vlastitih likova i pozadina. Stvaranje ravne linije omogućava 

pritisnuta tipka Shift dok se mišem povlači linija. Stvaranje linije prema točkama: mišem se odabere 

početna točka, pritisne se tipka Shift te se potom miš otpusti i klikne na završnu točku nakon čega se pojavi 

tražena linija. Stvaranje pravilne elipse ili pravilnog pravokutnika omogućava pritisnuta tipka Shift dok se 

standardnom metodom stvara pravokutnik ili elipsa. 

1.4.1 Primjer 

U primjeru 1, prikazane su opcije korištenja alata rectangle i ellipse, odnosno njihovi načini (mode). Mode 

predstavlja rad sa skupovima, odnosno gdje crtajući određene likove, dolazi do preklapanja ili spajanja 

likova.  

Postoje četiri različita načina i to prvi predstavlja normalan način odnosno zamjenjuje trenutno odabrano, 

drugi dodaje trenutno odabranom području, treći izuzima trenutno odabrano, a četvrti izdvaja dio koji se 

preklapa. 
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1.4.2 Primjer 

Primjer prikazuje način crtanja 3d kocke, bojana s gradijent efektom. Umjesto alata Rectangle, može se 

koristiti alat Free Select. 
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1.4.3 Primjer 

Primjer prikazuje način korištenja alata Paths, kojim se stvara vlastiti lik, na kojem se kasnije koriste razni 

filteri. Alatom Paths se postavljaju točke koje povezuju linijama, koje se potom mogu oblikovati na željeni 

način. Kako bi se lik zatvorio potrebno je odabrati tipku Ctrl i s lijevim klikom miša zatvoriti lik. Kako bi se 

oblik označio nakon čega se može bojati pripadni oblik, odabire se opcija unutar Tool Options > Selection 

from Path. 
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 Kako bi se dobio efekt sjene, prvo se treba povećati izvorni lik, s opcijom Grow Selection, dodati 

gradijent (sve na novom sloju). 
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 Potrebno je zamijeniti redoslijed slojeva. 
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 Primijeniti filter na način da se odaberu opcije Select none, Filters > Light and shadows > Drop 

shadow. 
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1.4.4 Zadatak 

 U novom dokumentu nacrtati lik/sliku prema želji korištenjem alata Paths, 

 Primijeniti filter po želji. 

 Dodati i oblikovati tekst prema želji. 

 Na Moodle priložiti projekt (xcf) s vidljivim svim slojevima. 

 

1.4.5 Primjer 

Cilj je napisati tekst oko zaobljenog objekta. 

 Otvoriti sliku nekog zaobljenog objekta u taj dokument, primjerice šalice. 

 Napisati tekst na tom objektu. 
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 Potrebno je proširiti granice sloja, jer prilikom korištenja alata Cage transform, dio teksta će se 

izbrisati. Odabrati s izbornika Layer opciju Layer Boundary Size > proširiti vrijednosti za širinu i 

visinu i korištenjem dugmeta Center centrirati tekst  > Resize. 
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 Potom se crta okvir (Cage) oko teksta i odabire Enter. 
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 Povlače se točke okvira kako bi se postavio željeni efekt s tekstom. 
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1.4.6 Primjer 

Cilj primjera je postići efekt da kroz slova nekog teksta se prozire neka druga slika. 

 Potrebno je odabrati alat Text Tool te napisati i oblikovati tekst po želji. 

 

 Odabrati Layer > Layer to Image Size. 
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 Odabrati sloj teksta i desnim klikom otvoriti izbornik te odabrati opciju Alpha to Selection te 

pritisnuti tipku Delete na tipkovnici. 

 

 

 

 

 

 

 

 

 

 



Haidi Božiković  80 

 Nakon što se odabere tipka Delete, dobivaju se slova koja su obrubljena isprekidanom linijom. 

 

 Nad slojem Background, desnim klikom odabrati opciju Add alpha channel te pritisnuti tipku 

delete, nakon čega se kroz slova više ne vidi pozadina već je prostor transparentan. 
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 Potom se dodaju slike, File > Open as layers i pripadni sloj se postavlja ispod postojećih slojeva. 

 

 Pozicija i veličina slike se namješta prema tekstu i opet odabire Layer > Layer to Image Size. 



Haidi Božiković  82 

 

 

1.4.7 Zadatak 

 U novom dokumentu ostvariti efekt prethodnog primjera (proziranje slike kroz određeni tekst). 

 Na Moodle priložiti projekt (xcf) s vidljivim svim slojevima. 

 

1.4.8 Primjer 

Cilj je postići efekt sjajnog dugmeta prikazanog na sljedećoj slici. 
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 Zbog potrebe orijentiranja može se dodati mreža prema kojoj se lakše određuju postavke lika, 

odnosno kao neka vrsta vodiča (engl. guides). 
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 Ako se želi dobiti pravilni krug, a ne elipsa, treba se držati tipka Shift pri korištenju alata Ellipse. 
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 Odrede se postavke za alat Blend i povuče se od centra prema van crta i otpusti. 
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 Potom se stvara novi sloj. 

 

 Odabere se alat Bucket Fill kako bi se krug bojao (unutar novog sloja), odabirući pokrivnu boju. 
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 Stvara se novi sloj. 

 

 Odabire se alat Blend i željene postavke. 
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 Stvara se novi sloj i na njemu se izvodi druga vrsta gradijenta. 
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 Stvara se novi sloj, koji se postavlja na dno svih slojeva, odnosno iznad sloja Background. 
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 Potom se odabire alat Blend. 
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 Stvoriti novi sloj, odabrati krug te desnim klikom odabrati opciju Select > To path. 
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 Odabrati opciju Select > None. 
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 Stvara se novi sloj koji se postavlja na vrh i briše se pomoćna mreža. 

 

 S alatom Path oblikuju se određena područja unutar dugmeta koja mu daju određenu 

specifičnost. Kreirati oblik te kada je oblik postane odgovarajući, odabrati opciju Selection To Path 

te obojiti po želji. S alatom Paths postavljaju se određena područja na kojima se dodaju željeni 

efekti. 
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 Na pripadni sloj se postavlja opcija Alpha to Selection. 

 

 Na novom sloju crta se završni dio dugmeta, primjerice oblik za dugme Play. 
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 Isključiti vidljivost sloja Background, a potom kako bi se dobila png slika dugmeta, koristi se opcija 

Export to. 

 

 

1.4.9 Zadatak 

Nacrtati jedno dugme prema želji sa sjajnim (glossy) ili nekim drugim efektom vodeći se primjerom (efekti, 

filteri, alat paths … ). Neka konačan rezultat ima barem 6 slojeva. Na Moodle priložiti projekt (xcf) s 

vidljivim svim slojevima. 
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2 Oblikovanje modernih stilskih predložaka internetskih stranica 

Teorijska osnova modernog dizajna i redizajna te oblikovanja stilskih predložaka internetskih stranica je 

detaljno objašnjena za vrijeme predavanja, a pripadni materijali (sa svim korištenim i objašnjenim 

primjerima) se nalaze na Moodle-u. Radi lakšeg snalaženja, u praktikumu su sažeto prikazana osnovna 

pravila i najčešće korištena svojstva CSS-a.  

2.1 Redizajn internetskih stranica 

2.1.1 Zadaci 

 Potrebno je s popisa (datoteka popis.zip) koji se nalazi na Moodle kolegiju, odabrati željenu 

internetsku stranicu i pripadni redizajn. Arhivirana datoteka popis.zip sadrži izgled pripadnih 

internetskih stranica. Primjerice, ws1-stari.jpg predstavlja stari dizajn internetske stranice, a ws1-

novi.jpg predstavlja novi dizajn internetske stranice, odnosno redizajn. 

 Odabrani redizajn je potrebno potvrditi na Moodle-u. 

 Prema teoriji dizajna/redizajna internetskih stranica s predavanja, potrebno je uočiti izvršene 

preinake i popisati ih prema elementima dizajna, odnosno prema smjernicama današnjeg dizajna 

internetskih stranica (prvi dojam, sadržaj, tekst, grafika, poveznice i slično). Odnosno za svaku 

uočenu preinaku, napisati što nije bilo u redu i na koji način je to promijenjeno. 

 Na kraju je potrebno dodati barem još jedan prijedlog kojim bi se mogao poboljšati izgled 

internetske stranice. 

 Vježbu predati u obliku tekstualnog dokumenta, u kojem se nalaze sve popisane preinake uz 

pripadne slike internetske stranice odabranog redizajna. 

 

2.2 Osnovna sintaksa i najčešće korištena svojstva CSS-a 

Kaskadni stilovi (engl. Cascading Style Sheets, CSS) omogućuju oblikovanje elemenata HTML dokumenta 

neovisno o samom sadržaju stranice pa je tako moguće definirati više vrsta stilova za jednu internetsku 

stranicu. Stilovi se preporučuju definirati u posebnoj tekstualnoj datoteci (ekstenzija css), a mogu se još 

definirati i u zaglavlju internetske stranice i linijski unutar sadržaja (korištenjem oznake <style>). Vezani 

predlošci (engl. linked) su predlošci koji se najčešće koriste, budući da se primjenjuju na više dokumenata, 

a definiraju na samo jedno mjesto. Za definiciju vezanog predloška koristi se oznaka link unutar zaglavlja 

dokumenta HTML-a (<link rel="stylesheet" type="text/css" href="predlozak.css" />).  

Pravilo CSS-a se sastoji od selektora, svojstva i vrijednosti u formatu selektor {svojstvo:vrijednost;} 

gdje selektor predstavlja određeni dio stranice koji će se oblikovati, svojstvo predstavlja određeni stilski 

element kojeg treba oblikovati, a vrijednost predstavlja određenu vrijednost svojstva. 

Postoji više vrsta selektora i to osnovni koji je istovjetan određenom HTML elementu (primjerice selektor 

body za oznaku body), potom selektori klase koji omogućuju da se isti stil može primijeniti na više 

elemenata iste klase (unutar stilskog predloška definira se .selekt_klase, a u HTML-u se postavlja klasa 

kao atribut class=selekt_klase) te selektor identifikatora čiji se stil obično primjenjuje za jedan element 

(unutar stilskog predloška definira se #selekt_id, a u HTML-u se postavlja id kao atribut id=selekt_id). 
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Ukoliko više selektora imaju isti stil, mogu se grupirati tako da se razdvoje zarezom i unutar vitičastih 

zagrada opiše stil. 

Selektor CSS-a podržava definiranje svojstava za više selektora u jednom pravilu korištenjem određenog 

kombinatora. Kombinator je skup sintaksnih pravila koja određuju veze između različitih elemenata HTML-

-a, a postoje četiri vrste kombinatora: 

1. Potomak (engl. descendant), E F, odnosno element F je ugniježđen unutar elementa E, a 

kombinator je prazan prostor (razmak). 

2. Dijete (engl. child), E > F, element F je izravno dijete elementa E. 

3. Susjedni brat (engl. adjacent sibling), E + F, element F se nalazi izravno poslije elementa E na istoj 

razini. 

4. Općeniti brat (engl. general sibling), E ~ F, element F se nalazi poslije elementa E, na istoj razini. 

CSS omogućava korištenje naprednih selektora, odnosno korištenje sljedećih selektora: 

- Selektori atributa omogućuju pristupanje elementima korištenjem atributa i pripadnih vrijednosti 

([atribut], selektor[atribut], selektor[atribut="vrijednost"] i drugi). 

- Pseudoklase omogućuju odabiranje elemenata temeljem svojstava koji nisu izravno definirani na 

elementu; dinamičke pseudoklase su :link, :visited, :hover, :active, :focus, a strukturne su 

:first-child, :nth-child, :last-child, :nth-of-type, :root, :empty, :target, :enabled, 

:disabled, :checked, :lang(jezik). 

- Pseudoelementi su dijelovi elementa koji se ne definiraju izravno unutar elementa (:first-

letter, :first-line, :before, :after).  

Svojstva CSS-a za oblikovanje teksta su: 

- Svojstvo font-family definira općeniti naziv obitelji ili naziv određene obitelji fonta. 

- Svojstvo font-size definira veličinu fonta (%, px, em, small, large i drugi). 

- Svojstvo font-style definira nakošenje fonta (normal, italic, oblique). 

- Svojstvo font-variant definira način prikazivanja fonta (normal, small-caps). 

- Svojstvo font-weight definira debljinu fonta (normal, bold, bolder, lighter). 

- Svojstvo font-stretch definira rastezanje fonta (normal, wider, narrower, condensed). 

Pravilo @font-face omogućava korištenje fonta sa određenog izvora. Ukoliko se koristi usluga Google 

Web Fonts, font nije potrebno pohraniti na vlastitom poslužitelju pa time nije ni potrebno koristiti pravilo 

@font-face, već je dovoljno staviti poveznicu unutar HTML dokumenta oznakom link na pripadni Google 

font. 

Svojstva koja se mogu koristiti za oblikovanje teksta sadržaja su sljedeća: 

- Svojstvo line-height definira prored (%, px, em, broj, brojčani faktor i drugi). 

- Svojstvo color definira boju teksta koja se može postaviti nazivom boje, RGB (engl. Red Green 

Blue), heksadecimalnom i HSL/A (engl. Hue Saturation Lightness Alpha) vrijednošću. 

- Svojstvo text-align definira horizontalno poravnanje teksta (left, right, center, justify). 

- Svojstvo text-decoration definira ukrašavanje teksta (underline, overline, line-through, 

blink, none). 

- Svojstvo text-indent uvlači prvu liniju teksta (px, em, % i drugi). 
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- Svojstvo text-transform definira formatiranje teksta (uppercase, lowercase, capitalize, 

none). 

- Svojstvo text-shadow definira sjenu teksta koja se postavlja sa vrijednostima horizontalnog 

odmaka, vertikalnog odmaka, radijusa zamućenosti i boje. 

- Svojstvo letter-spacing povećava ili smanjuje razmak između znakova (engl. tracking). 

Svojstva kojima se može upravljati oznakama elemenata liste su sljedeća: 

- Svojstvo list-style-type definira vrstu oznake elementa liste (disc, circle, square, decimal, 

decimal-leading-zero, lower-roman, upper-roman, lower-alpha, upper-alpha, lower-greek, 

none). 

- Svojstvo list-style-image definira sliku koja se prikazuje kao oznaka (url(lokacija_slike)). 

- Svojstvo list-style-position definira poziciju oznake u odnosu na tekst (inside, outside 

(initial)). 

Tablica se može oblikovati korištenjem sljedećih svojstava: 

- Svojstva width i height definiraju širinu i visinu tablice. 

- Svojstvo border definira obrub tablice (zadano ponašanje tablice ne prikazuje obrube). 

- Svojstvo border-collapse - prilagođava obrub tablice (poništavaju se dvije linije u jednu, 

odnosno linije od tablice i linije od ćelija th/td). 

- Svojstvo border-style definira stil obruba (dotted, dashed, solid, double, groove, rigde, 

inset, outset) . 

- Svojstvo padding definira udaljenosti sadržaja od rubova ćelija. 

- Svojstvo border-spacing definira razmak između dviju ćelija, odnosno obruba dviju susjednih 

ćelija (vrijedi kod dvostrukih obruba, vrijednost separate svojstva border-collapse, dok kod 

vrijednosti collapse ne vrijedi). 

- Svojstvo text-align definira horizontalno poravnanje sadržaja th i td ćelije (left, right, 

center); zadano je da je sadržaj th ćelija centriran, a td da je ulijevo poravnan. 

- Svojstvo vertical-align definira vertikalno poravnanje (top, bottom, or middle) th i td ćelija, a 

zadana vrijednost je middle. 

- Svojstvo table-layout definira shemu prikazivanja tablice (fixed, auto). Zadana vrijednost je 

auto, u kojoj se širina tablica definira prema najširoj ćeliji, dok širina sheme fixed je određena 

širinom tablice i stupaca, a ne samim sadržajem. 

Svojstva koja se mogu koristiti za upravljanje podlogom elementa HTML-a su: 

- Svojstvo background-color definira boju podloge (naziv boje, heksadecimalna vrijednost, RGB/A, 

HSL/A). 

- Svojstvo background-image definira sliku na podlozi (url(lokacija_slike)). 

- Svojstvo background-repeat definira ponavljanje slike (repeat, repeat-x, repeat-y, no-

repeat). 

- Svojstvo background-attachment definira hoće li se slika pomicati kako se pomiče stranica 

(scroll, fixed). 

- Svojstvo background-position definira poziciju slike (top left, top center, top right, center 

left, center center, center right, bottom left, bottom center, bottom right, x% y%, x-

pozicija y-pozicija). 
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- Svojstvo background-origin definira poziciju slike podloge (border-box, padding-box, 

content-box; border-box). 

- Svojstvo background-clip definira platno podloge (border-box, padding-box, content-box). 

- Svojstvo background-size definira veličinu podloge gdje vrijednost CSS3-a contain omogućuje 

povećanje slike do njenog maksimuma,  no prema okvirima spremnika slike, tako da se mogu naći 

određena područja spremnika na kojem se dio slike ne nalazi, a vrijednost cover predstavlja 

povećanje slike tako da potpuno popuni prostor spremnika slike, gdje je moguće da se dogodi 

situacija da se dio slike ne vidi. 

Svojstva koja se mogu koristiti za upravljanje obrubom određenog sadržaja su: 

- Svojstvo border-style definira vrstu iscrtanog obruba (solid, dashed, dotted, inset, outset, 

ridge, groove, double, hidden, none). 

- Svojstvo border-color definira boju obruba. 

- Svojstvo border-width definira debljinu obruba (px, thin, medium, thick i drugi). 

- Svojstvo border-radius definira zaobljenost rubova (px, definiraju se rubovi redom gornje lijevi, 

gornji desni, donji desni, donji lijevi). 

Svojstvo koja se može koristiti za upravljanje odmakom određenog sadržaja, odnosno veličinom praznog 

prostora oko sadržaja elementa je padding ili pojedinačno padding-bottom, padding-left, padding-

right, padding-top.  

Svojstvo koje se može koristiti za upravljanje odmakom određenog sadržaja, odnosno veličinom 

udaljenosti sadržaja od ruba je margin ili pojedinačno margin-top, margin-right, margin-bottom, 

margin-left. 

Novo svojstvo CSS3-a box-sizing pojednostavljuje definiranje širine elementa (vrijednost content-box 

označava situaciju gdje su u širinu elementa uključene vrijednosti odmaka i obruba, a vrijednost border-

box označava situaciju gdje u širinu elementa nisu uključene vrijednosti obruba i odmaka). 

Svojstvo position definira četiri različite vrste pozicioniranja, odnosno vrijednost static (zadana 

vrijednost) i vrijednost relative definiraju elemente unutar normalnog toka, dok vrijednosti absolute i 

fixed pomiču elemente van normalnog toka. Za statično pozicioniranje koriste se svojstva margin i 

padding, dok se za relativno, apsolutno i fiksno pozicioniranje koriste par svojstava top, right, bottom i 

left.  

Svojstvo float predstavlja hibridni tok oblikovanja internetske stranice, gdje se prati normalan tok 

internetske stranice, no dio elementa se postavljaju desno ili lijevo. Vrijednosti svojstva float mogu biti 

left, right, none. Kako bi svojstvo float funkcioniralo, potrebno je obavezno navesti širinu elementa. 

Nakon korištenja svojstva float, potrebno je poništiti pravilo svojstvom clear (koji može imati vrijednosti 

both, left, right, none) kako bi se spriječio proces umotavanja narednih elemenata. Primjenu svojstava 

float-clear može zamijeniti primjena svojstva display vrijednost inline-block. Preostale moguće 

vrijednosti svojstva display su inline, block, list-item, none. 

Transformacije (svojstvo transform), tranzicije (svojstvo transition) i animacije (svojstvo animation) 

predstavljaju novitete CSS3-a. Transformacije omogućavaju upravljanje sa pozicijom, veličinom, rotacijom 

i iskrivljenošću elementa (2d i 3d funkcije – translate(), scale(), rotate(), skew()). Tranzicija 

omogućava da se vrijednost svojstva elementa blago promjeni kroz određeni vremenski interval, a 
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promjena se postavlja u odnosu na početno i završno stanje. Kod korištenja tranzicije obavezno je 

naznačiti svojstvo nad kojim se tranzicija izvodi. Definiranje tranzicije obuhvaća korištenje svojstava 

transition-property, transition-duration, transition-timing-function, transition-delay. 

Animacija omogućava promjenu svojstava elementa u više stanja (engl. keyframes) kroz određeni 

vremenski interval. Svako stanje animacije se pojedinačno definira. Svaki vremenski interval definiran je 

postotkom, a obuhvaća jedan ili više stilova. Svojstvo animation povezuje animaciju sa selektorom 

definiranjem naziva i vremena trajanja animacije (animation-name, animation-duration, animation-

timing-function, animation-delay, animation-iteration-count, animation-direction). Pravilo 

@keyframes oblikuje animaciju i pripadne promjene stilova (@keyframes nazivAnimacije {keyframes-

selektor {/*stilovi*/} }).  

Kod prikazivanja novih svojstava CSS3-a kao što su svojstva transform, transition i animation, postoji 

mogućnost da ih preglednici ne podržavaju pa je bitno koristiti prefikse svakog pojedinačnog preglednika 

(Mozilla -moz-, Chrome i Safari –webkit-, Opera -o-, Internet Explorer -ms-). 

Osnovne komponente responzivnog internetskog dizajna su medijski upiti za različite uređaje, 

prilagodljiva mreža (engl. grid) i prilagodljive slike i prilagodljiva tipografija. Definiranje ključnih točaka 

(engl. breakpoints) se dodaju kod definiranja različitih stilova za različite uređaje. Najčešće korištene 

ključne točke su: najmanji uređaji (npr. mobiteli, rezolucija manja od 768px), mali uređaji (npr. tableti, 

768-992px), srednji uređaji (npr. osobna računala, 992-1200px) i veliki uređaji (npr. osobna računala, veće 

od 1200px). Kod oblikovanja responzivnih internetskih stranica jako je bitno definirati meta oznaku 

viewport koja predstavlja veličinu prozora preglednika, odnosno područje unutar kojeg se nalazi 

internetska stranica. Stranice kojima nije viewport postavljen, prikazuju se u punoj veličini kao što se 

prikazuju na osobnim računalima. Definiranje viewporta se sastoji se od parova ključ/vrijednost koji su 

odvojeni zarezom (atribut width definira širinu viewporta koja ako nije postavljena tada se uzima zadana 

vrijednost za taj uređaj, vrijednost initial-scale definira veličinu stranice kada se prvi put učita, a ako 

se postavi da je 1, tada će biti određena vrijednošću atributa width te neće biti uvećana/umanjena, 

maximum-scale omogućava da se korisnicima zabrani uvećavanje po želji, user-scalable 

omogućava/onemogućava uvećanje internetske stranice, a po zadanome je dozvoljeno). Medijski upiti 

(engl. media queries) su jednostavan, ali moćan alat za aktiviranje određenih svojstava CSS-a, ovisno o 

pregledniku i osobinama uređaja (width, height, device-width, device-height, aspect-ratio, 

device-aspect-ratio, pixel-ratio, device-pixel-ratio, orientation resolution, color). 

Medijski upiti se sastoje od definicije barem jednog medijskog tipa i jednog ili više medijskih izraza 

(@media all and (max-width: 1024px) {...} ). Medijski izrazi se mogu povezivati logičkim 

operatorima (and, or, not, only). Primjer medijskog upita je definiran kao @media screen and (max-

width: 600px){ /*css pravilo*/} gdje pravilo CSS-a vrijedi za sve vrijednosti širine zaslona ispod 

600px.  

 

2.2.1 Zadaci 

2.2.1.1 Zadatak 

Prema praktičnim primjerima s predavanja, oblikovati svoj stilski predložak prema sljedećim smjernicama: 

 Izraditi internetsku stranicu sa smislenim tekstom i slikama po želji. 

 Stil definirati u posebnoj datoteci. 
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 Oblikovati stil za prikazane naslove i tekst na internetskoj stranici (svojstva teksta i fonta; može se 

koristiti Google fonts ili slično). 

 Postaviti podlogu internetske stranice prema želji. 

 Pri definiranju boja potrebno je barem jedanput koristiti zapis RGBA i HSLA. 

 Na Moodle priložiti sve korištene datoteke u obliku arhivirane datoteke. 

 

 

2.2.1.2 Zadatak 

Prema praktičnim primjerima s predavanja, oblikovati svoj stilski predložak prema sljedećim smjernicama: 

 Nadograditi internetsku stranicu iz prethodnog zadatka. 

 Oblikovati smislenu shemu internetske stranice prema želji (float, flex ili drugi). 

 Oblikovati navigaciju, vertikalnu ili horizontalnu, korištenjem nenumerirane liste (mogu se koristiti 

i prazne poveznice). 

 Internetsku stranicu je potrebno oblikovati prema određenoj shemi boja (navesti koja i razlog 

korištenja). 

 Na Moodle priložiti sve korištene datoteke u obliku arhivirane datoteke. 

 

2.2.1.3 Zadatak 

Prema praktičnim primjerima s predavanja, oblikovati svoj stilski predložak prema sljedećim smjernicama: 

 Nadograditi internetsku stranicu iz prethodnog zadatka s elementima transformacije i promjene 

(barem dvije od svake) te s barem dvije animacije. 

 Na Moodle priložiti sve korištene datoteke u obliku arhivirane datoteke. 

 

2.2.1.4 Zadatak 

Prema praktičnim primjerima s predavanja, oblikovati svoj stilski predložak prema sljedećim smjernicama: 

 Nadograditi internetsku stranicu iz prethodnog zadatka tako da bude prilagođena za prikazivanje 

na različitim uređajima. 

 Na Moodle priložiti sve korištene datoteke u obliku arhivirane datoteke. 

 

2.2.1.5 Zadatak 

Prema praktičnim primjerima s predavanja, oblikovati svoj stilski predložak prema sljedećim smjernicama: 

 Oblikovati novi stilski predložak za postojeću internetsku stranicu korištenjem predloška 

Bootstrap. 

 Na Moodle priložiti sve korištene datoteke u obliku arhivirane datoteke. 
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